Problema detección discos en PowerEdge 1900

Servidores

Servidores
Soporte, consejos y tutoriales sobre Servidores Dell

Problema detección discos en PowerEdge 1900

Esta pregunta ha sido respondida por DELL-FranciscoF

Buenas, 

Tenemos un servidor PowerEdge 1900 con RAID y 2 discos duros, aunque solo se usa uno. La cuestión es que se bloquearon unos servicios, y al reiniciar el ordenador, parece no detectar los discos. Lo hemos probado incluso arrancando con los discos con los cables quitados y dice lo mismo que con los cables conectados a ellos. 

Concretamente, este error nos da en el proceso de arranque:

-----------

F/W initializing devides 0%

ha-0 (bus 2 dev 14) PERC 5/i integrated

FW package: 5.2.1.-0067

0 logical drive(s) found on the host adapter

0 logical drive(s) handled by BIOS

---------

¿Qué puede estar pasando?

Gracias por su ayuda,

Juan Manuel García

Respuesta comprobada
  • Hola Juan Manuel,

    Sí, parece que hay un doble fallo de disco, ¿cuantos discos llevaba originalmente el server?

    El hecho que los dos discos aparezcan con tamaño 0, nos dá pocas esperanzas respecto a posibles intentos de recuperación, no obstante, si tenían originalmente un RAID 1 con ambos discos, en la vista de discos físicos, presionar sobre por ejemplo el 00:00 F2, y elegir la opción force online, con lo cual podrían intentar arrancar el servidor a ver si le arranca el S.O.

    Es bastante interesante para el diagnóstico si me envía el reporte DSET sacado con SLI 2.2 por correo privado.

    Gracias y saludos.

Todas las respuestas
  • Buenos Dias Juan Manuel,

    Lo mas probable es que los discos estén en estado foreign. Para comprobarlo, entrar en el Ctrl+R, y ver el estado de los discos físiscos presionando Ctrl+N, si estuviesen en foreign, ir atras con ctrl+P, ir a cotroller 0->F2 -> foreign configuration-> import-> yes.

    Con esto deberían de aparecer de nuevo los RAIDs anteriores. Si no apareciesen, para comprobar qué es lo que está ocurriendo, sería conveniente extraer un DSET de la máquina, para ello, arrancando con esta imagen el server: http://dell.to/1HBCGLo

    Y siguiendo las instrucciones de la página 16 del PDF http://dell.to/1HBCRpT  tiene las instrucciones para generarlo, ¿me podría enviar el .zip generado por mensaje privado?

    Gracias y saludos.

  • Buenas, gracias.

    Intentaremos hacer todo esto y le informamos. Si es necesario, podemos mandarla información por privado, claro.

    Muchas gracias.

    Juan Manuel

  • Buenas,

    Hemos entrado con Crtl+R

    Lo primero que nos sale es:

    Controler 0

       - No Configuration Present

    Ctrl + N

       - Vemos dos discos y ambos: 00:00 y 00:01 Seagate, tamaño 0, SAS, Failed

    Intentamos operar y todas las opciones están desactivadas.

    Vamos a pantalla anterior Ctrl+P, puslamos de nuevo F2 y todas las opciones desactivadas. No podemos importar.

    ¿Seguimos con la prueba que nos comenta con la imagen del server?

    Gracias,

    Juan Manuel

  • Hola Juan Manuel,

    Sí, parece que hay un doble fallo de disco, ¿cuantos discos llevaba originalmente el server?

    El hecho que los dos discos aparezcan con tamaño 0, nos dá pocas esperanzas respecto a posibles intentos de recuperación, no obstante, si tenían originalmente un RAID 1 con ambos discos, en la vista de discos físicos, presionar sobre por ejemplo el 00:00 F2, y elegir la opción force online, con lo cual podrían intentar arrancar el servidor a ver si le arranca el S.O.

    Es bastante interesante para el diagnóstico si me envía el reporte DSET sacado con SLI 2.2 por correo privado.

    Gracias y saludos.

  • Siempre ha tenido dos discos, pero creo que solo se estaba usando 1 disco en realidad con el sistema funcionando y ya está. Por lo que me resulta extraño que no detecte ninguno. Incluso pusimos linux a ver si reparaba el sistema y nos dice que no puede.

    Estaba funcionando y tal como intentamos reiniciar por fallos que comenzó a dar, se quedó así.

    No sabemos si se podrían formatear los discos y comenzar de 0 o están muertos del todo los discos.

    Nos resulta muy raro todo.

    Intentaremos hacer el DSET pero no sabemos como lo vamos a sacar en ZIP de la máquina. ¿Cógera un pen o algo para sacar el archivo que genere?

    Juan Manuel

  • Efectivamente, una vez arrancado el liveDVD e insertado el pen drive USB lo montará automáticamente y puede copiar el .zip del DSET generado.

    Gracias y saludos.

  • Buenos días,

    No he recibido todavía el DSET, ¿le puedo ayudar en alguna otra cosa en este caso?

    Gracias