Configuracion VLAN Switch PowerConnect 6248P

Conectividad / Networking

Conectividad / Networking
Soporte, consejos y tutoriales sobre Redes, Switches y Dell Networking

Configuracion VLAN Switch PowerConnect 6248P

Esta pregunta ha sido respondida por Dell-JuanE

hola buenos dias,

busque por todos los medios poder publicar un tema nuevo pero no encontre, que pena por realizar mu pregunta desde aqui, pero necesito de verdad colaboracion para un problemita que tengo con la configuracion de un switch powerconnect 6248p! .... plantearre mi inquietud, espero me puedan ayudar!!

tengo creadas dos vlan y la vlan por defecto, las tengo enrutadas y entre se comunican excelentemente. El switch lo tengo konectado a un router cisco, el puerto donde esta conectado esta en forma general con pvid 1 y add a las vlan que tengo creadas.... el problema que tengo esque las vlan qe cree no me navegan y tampoco se comunican a la vlan por defecto. La vlan por defecto si navega pero tampoco me deja ver los computadores de las otras vlans....

1. como puedo hacer, o que le configuro al switch para  que las vlan creadas tengan acceso a internet?

2.la vlan por defecto o de adminsitracion, no la pueden acceder por ser la de administracion?

3. como puedo hacer para que la vlan por defecto se comunique con las otras vlan's?

4. este problema no tiene solucion?

5. que tipo de cable debo usar para conectar el switch con el router, directo o cruzado??

espero me puedan colaborar estare atenta a sus respuesta!

muchas gracias, mil bendiciones!

Respuesta comprobada
  • Muy buenas tardes Yuliethbv,

    Por lo que nos comenta en el post entendemos lo siguiente:

    • En el Switch hay un puerto como trunk modo general por donde se declaran todas la vlan tanto

           tagueadas como no tagueadas.

    • Para que cierta vlan tenga conexión a internet debe haber una forma en la que al intentar

           conectarse a una ip pública el paquete sepa que debe dirigirse al Gateway el cual debe ser un

           puerto del router para tener salida al mundo exterior.

    Lo que recomendamos es lo siguiente:

    • Entiendo que para tener conexión desde una vlan a internet debe haber una ruta estática hacia

           un Gateway, el cual suele ser el puerto que la comunica al router desde donde el paquete es

           ruteado hacia internet o al mundo exterior. Al confirmar que el paquete va dirigido a una dirección

           IP que no se encuentra en el segmento local, este será dirigido hacia el Gateway (router) para

           salir a internet.

    • Por otro lado también veo que necesita comunicación entre vlans por lo que recomiendo

           configurar un “router on a stick” en el puerto del Cisco para que sea este equipo el que haga la

           comunicación entre las vlan.

    o Se crearían subinterfaces en el  puerto que comunica con el router Cisco, una por cada vlan,

           configurando algún protocolo de ruteo que se encargue de redirigir los paquetes entre las vlan.

           Puede ser a base de rutas estáticas si la red es chica o protocolos de enrutamiento dinámico

           como puede ser RIPv2 u OSPF.

    Esta última configuración no es algo sencillo si el cliente no lo tiene ya implementado en su router, se recomienda que en caso de que por alguna razón el cliente no pueda realizarla, solicite el servicio de Remote Advisory Service / Remote Installation Service.

    Respondiendo literalmente a sus preguntas:

    1. Como puedo hacer, o que le configuro al switch para  que las vlan creadas tengan acceso a  

           Internet?

    • Se debe crear una ruta estática al Gateway.

    2. La vlan por defecto o de administración, no la pueden acceder por ser la de administración?

    • Al estar en modo general debería pasar la vlan default o de administración. Habría que verificar

           como está configurada en el otro extremo ya que esto debe coincidir en cuanto a la vlan nativa en

           ambos extremos del switch / router, (depende de la configuración). Si no se declara ninguna vlan

           el trunk por defecto pasara todas las vlan y los puertos que estén declarados en estas.

    3. Como puedo hacer para que la vlan por defecto se comunique con las otras vlan's?

    • Se puede configurar un esquema de enrutamiento en el router cisco o se crea un trunk sin

           declarar ninguna vlan en el para que pasen automáticamente todas. Esto solo aplica a un trunk

           que va de siwtch a switch directamente mas no uno que conecte hacia el router.

    4. Este problema no tiene solución?

    • Según lo veo (sin tener datos específicos) es cuestión de configuración de ruteo.

    5. Qué tipo de cable debo usar para conectar el switch con el router, directo o cruzado?

    • Según la teoría de cisco este debe ser directo o EIA-TIA568B-EIA-TIA568A o sea directo ya que el

          “pinout” del router es distinto al del switch.

    Esperamos que esta información le ayude a corregir el inconveniente que nos reporta.

    De surgir alguna consulta adicional, estamos a la orden.

    Saludos cordiales,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

  • Buenas tardes yuliethbv,

    Efectivamente seguiríamos el mismo principio que lo que le comentaron en soporte. Esto ya sería un servicio que se cobra ya que para poder dar una asesoría correcta es necesario realizar un assesment del ambiente del cliente. Normalmente esto implica una visita en sitio y correr una herramienta llamada Laso para hacer un levantamiento de la red. Una vez que se tiene todos los datos se puede dar una asesoría correcta.

    El que no navegue puede ser por muchas razones. Una de ellas puede ser por problemas de configuración de enrutamiento. También podría ser por falta de alguna regla en algún firewall.

    La razón de que no navegue la vlan1 puede ser que efectivamente esta sea nativa en un extremo del trunk pero no en el otro. La información de cómo configurar la vlan nativa la encontrara en el manual de cada switch.

    Lamentablemente no brindamos servicio de configuración gratuito. Se recomienda que llame por teléfono a un asesor de su cuenta para que le coticen el servicio de Remote Advisory Service.

    Saludos,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

    Siguenos en @DellAyudaPRO nuestro nuevo canal de soporte.

  • Buenas tardes Yuliethbv,

    La configuración del ruteo debe ser configurada en el swtich Cisco ya que este equipo tendría la finalidad de re direccionar los paquetes hacia internet o desde este. También se debe configurar en este el NAT para traducir de IP’s públicas a privadas y al revés para tener acceso a internet. Resumiendo, estos dos servicios deben estar configurados en el router.

    Le muestro una configuración típica de un NAT configurado en un Router Cisco:

    interface FastEthernet0/0

    ip address 192.168.100.30 255.255.255.240

    ip nat inside

    duplex auto

    speed auto

    !

    interface Serial0/0

    ip address 192.0.2.113 255.255.255.0

    encapsulation frame-relay

    ip nat outside

    !

    ip nat pool mypool 198.18.184.105 198.18.184.110 netmask 255.255.255.248

    ip nat inside source list 1 pool mypool overload

    ip classless

    !

    !

    access-list 1 permit 192.168.100.16 0.0.0.15

    !

    !

    Si requiere más asistencia con respecto a la configuración que esta realizando, por favor proceda a contactar nuestro departamento de Soporte Técnico para Servidores.

    Saludos cordiales,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

    Síguenos en @DellAyudaPRO nuestro nuevo canal de soporte.

  • Buenas tardes Yuliethbv,

    Por favor mándenos un correo a la dirección ts_prosupport@dell.com con su número de teléfono,  un Especialista del Departamento de Soporte Técnico para Servidores Dell le estará llamando a la brevedad posible para esclarecer cualquier duda que tenga.

    Saludos cordiales,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

    Síguenos en @DellAyudaPRO nuestro nuevo canal de soporte.

Todas las respuestas
  • Hola buenos dias... Podrias colocar los running para entender mejor lo que planteas

  • Muy buenas tardes Yuliethbv,

    Por lo que nos comenta en el post entendemos lo siguiente:

    • En el Switch hay un puerto como trunk modo general por donde se declaran todas la vlan tanto

           tagueadas como no tagueadas.

    • Para que cierta vlan tenga conexión a internet debe haber una forma en la que al intentar

           conectarse a una ip pública el paquete sepa que debe dirigirse al Gateway el cual debe ser un

           puerto del router para tener salida al mundo exterior.

    Lo que recomendamos es lo siguiente:

    • Entiendo que para tener conexión desde una vlan a internet debe haber una ruta estática hacia

           un Gateway, el cual suele ser el puerto que la comunica al router desde donde el paquete es

           ruteado hacia internet o al mundo exterior. Al confirmar que el paquete va dirigido a una dirección

           IP que no se encuentra en el segmento local, este será dirigido hacia el Gateway (router) para

           salir a internet.

    • Por otro lado también veo que necesita comunicación entre vlans por lo que recomiendo

           configurar un “router on a stick” en el puerto del Cisco para que sea este equipo el que haga la

           comunicación entre las vlan.

    o Se crearían subinterfaces en el  puerto que comunica con el router Cisco, una por cada vlan,

           configurando algún protocolo de ruteo que se encargue de redirigir los paquetes entre las vlan.

           Puede ser a base de rutas estáticas si la red es chica o protocolos de enrutamiento dinámico

           como puede ser RIPv2 u OSPF.

    Esta última configuración no es algo sencillo si el cliente no lo tiene ya implementado en su router, se recomienda que en caso de que por alguna razón el cliente no pueda realizarla, solicite el servicio de Remote Advisory Service / Remote Installation Service.

    Respondiendo literalmente a sus preguntas:

    1. Como puedo hacer, o que le configuro al switch para  que las vlan creadas tengan acceso a  

           Internet?

    • Se debe crear una ruta estática al Gateway.

    2. La vlan por defecto o de administración, no la pueden acceder por ser la de administración?

    • Al estar en modo general debería pasar la vlan default o de administración. Habría que verificar

           como está configurada en el otro extremo ya que esto debe coincidir en cuanto a la vlan nativa en

           ambos extremos del switch / router, (depende de la configuración). Si no se declara ninguna vlan

           el trunk por defecto pasara todas las vlan y los puertos que estén declarados en estas.

    3. Como puedo hacer para que la vlan por defecto se comunique con las otras vlan's?

    • Se puede configurar un esquema de enrutamiento en el router cisco o se crea un trunk sin

           declarar ninguna vlan en el para que pasen automáticamente todas. Esto solo aplica a un trunk

           que va de siwtch a switch directamente mas no uno que conecte hacia el router.

    4. Este problema no tiene solución?

    • Según lo veo (sin tener datos específicos) es cuestión de configuración de ruteo.

    5. Qué tipo de cable debo usar para conectar el switch con el router, directo o cruzado?

    • Según la teoría de cisco este debe ser directo o EIA-TIA568B-EIA-TIA568A o sea directo ya que el

          “pinout” del router es distinto al del switch.

    Esperamos que esta información le ayude a corregir el inconveniente que nos reporta.

    De surgir alguna consulta adicional, estamos a la orden.

    Saludos cordiales,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

  • ola, emmm que pena solo responder hasta ahora :$ esque no habia podido atender sus respuestas, las e estado leyendo, y las pondre en practica, yo les escribo para comentarle como sale todo! y seguir recibiendo sus opiniones que para mi son muy valiosas e importantes!

    una cosita si qiero recarlcar,

    el switch no me recibe ruta estatica para el gateway ni del router ni la ip de el mismo qe me sirva de enlace o puente para llegar al router :s .... el resto de las opciones, las voy a usar y les comento como me fue! muchisias gracias por su colaboracion :) bendiciones ^^

  • buenas tardes, vuelvo yo por aki.... :)

    ya coloke la ruta estatica que me dices para que salga a internet quedo asi

    ip route 0.0.0.0 0.0.0.0 190.0.50.130

    pero de igual manera no me navegan, otra koza los equipos no dan ping a la ip del switch :/

    como hago para asignarle una ip a un solo puerto, pues no e sido kapas!

    como asigno la vlan de administracion a otra que no sea la predeterminada??

    las vlan se comunican excelentemente entre ellas.

    finalmente kuanco hago tracert al router o a alguna pagina de internet para ver en que parte se quedan los paquetes de la puerta de enlace de la vlan no pasa, llega hasta ahy y dice red de destino inalcansable! que puedo hacer? que solucion me sugieren???

  • Buenas tardes yuliethbv,

    Respondiendo a su consulta, Según vemos se resolvió el problema de comunicación entre las vlan y estas llegan hasta el puerta de enlace usando la ruta estática. Si la vlan no es capaz de llegar hacia el exterior (internet) desde el Router, es claro que debe verificar la configuración de enrutamiento que tiene en este.

    También cabe mencionar que en las recomendaciones anteriores habíamos sugerido configurar un puerto trunk en el switch por donde pasen las vlan que necesitan internet. Adicional a esto, debe tener un protocolo de enrutamiento configurado y un Nat para que se le asigne una IP publica (o de internet) a una IP privada y así los equipos puedan conectarse a internet de forma segura. Esto se puede implementar en el router o se puede implementar un Servidor de NAT o un Proxy Server.

    Por favor recuerde que esta configuración es necesaria para que los equipos puedan tener acceso a internet.

    Si el switch es un Power Connect no se puede asignar IP a un solo puerto. Debiera ser a una vlan. Si el switch es un Dell Force10 si se podría asignar una IP a un solo puerto. La vlan de administración efectivamente puede ser cambiada por cualquier otra como vlan nativa. Esto depende del modelo del switch. Recomiendo verificar el manual en línea en la página de www.support.dell.com.

    Esta es una configuración posible entre varias dependiendo del ambiente. Esta no es una configuración sencilla y abarca varias etapas. Le recomendamos que si tiene problemas con dicha implementación, se contacte con nuestro departamento de Soporte Técnico para adquirir un Servicio de Configuración o Implementación Remota. Luego de una validación del ambiente del cliente se procedería con las configuraciones pertinentes para dejarle funcionando la conexión a internet.

    Saludos,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

      Siguenos en @DellAyudaPRO nuestro nuevo canal de soporte.

  • buenos dias :)

    leyendo lo que me sugieres me surgen las siguientes inquietudes:

    1- cuanto dices protocolo d enrutamiendo y nat; esto es para aplicarlo al switch o va solamente en el router?

    2- yo ya cree el puerto trunk que me dice, pero cuando conecto el cable que va desde el router(el de internet) no me deja navegar nisiqiera la vlan 1, por eso lo tengo en modo general!

    yo anteriormente ya habia llamado a pedir soporte pero me dijeron que ellos solo daban soporte por hardware que ya configuracion y eso me colaboraban y todo pero ya tenia un costo por la asesoria :/ por eso estoy aqui realizando preguntar para realizar la configuracion por mi parte :$

    lo de el kambio de la vlan nativa que mencionas, eso lo encuentro en los manuales? o tendria que investigar por aparte?? :) ........ quiero darle las gracias por su atencion :) me a sido muy util

  • Buenas tardes yuliethbv,

    Efectivamente seguiríamos el mismo principio que lo que le comentaron en soporte. Esto ya sería un servicio que se cobra ya que para poder dar una asesoría correcta es necesario realizar un assesment del ambiente del cliente. Normalmente esto implica una visita en sitio y correr una herramienta llamada Laso para hacer un levantamiento de la red. Una vez que se tiene todos los datos se puede dar una asesoría correcta.

    El que no navegue puede ser por muchas razones. Una de ellas puede ser por problemas de configuración de enrutamiento. También podría ser por falta de alguna regla en algún firewall.

    La razón de que no navegue la vlan1 puede ser que efectivamente esta sea nativa en un extremo del trunk pero no en el otro. La información de cómo configurar la vlan nativa la encontrara en el manual de cada switch.

    Lamentablemente no brindamos servicio de configuración gratuito. Se recomienda que llame por teléfono a un asesor de su cuenta para que le coticen el servicio de Remote Advisory Service.

    Saludos,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

    Siguenos en @DellAyudaPRO nuestro nuevo canal de soporte.

  • una inquietud, yo creo rutas estaticas pero el switch no me las acepta, al darle el comando show ip route solo me salen las rutas conectadas, es decir, las ip's de las vlan's las rutas que yo creo no me aparecen por tanto ps creo qe no funcioan! como hago para que las agregue y las tenga en cuenta? o que estare haciendo mal al momento de crearlas?

    (yo las creo con el comando ip route)

  • Buenas tardes yuliethbv,

    El que las rutas queden o no en la tabla de enrutamiento depende del protocolo de enrutamiento. Por ejemplo: Si se usa un OSPF es este el que decidirá que ruta es la más idónea para alcanzar una red, por lo tanto descartara las demás. Si está usando un protocolo como RIPv2 solo debería añadir las rutas hacia las redes que ve directamente el switch / Reuter para que él tenga conocimiento de hacia dónde enviar el paquete. Este último protocolo es un protocolo tipo “Distance Vector” el cual manda toda su tabla de enrutamiento al switch vecino pero esto no quiere decir que va a tener todas estas rutas en su tabla de enrutamiento.

    En un ejemplo como este:

     

    El router 2811 Ru-Rt solo tiene una ruta estática hacia cada red. Esto es suficiente para que el equipo sepa hacia dónde dirigir el paquete.

    Si no tiene un protocolo de enrutamiento como este con solo rutas estáticas, es probable que el protocolo sea dinámico, con lo que no vera todas las rutas en la tabla de ruteo al hacer un “show ip route”.

    Saludos,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

    Síguenos en @DellAyudaPRO nuestro nuevo canal de soporte.

  • para resumir, ya que todo los anterior esta hecho y el unico inconveniente que me falta por resolver es la navegacion de los equipos conectados a las vlan hacia intenet, se puede decir que la solucion reside en aplicar un protocolo de enrutamiento y el NAT que me habia mencionado en la publicacion anterior!!!

    lo uniko que no que no me qeda klaro es: esta solucion se la aplicaria al switch powerconnect o al router cisco para finalmente solucionar la problematica???

  • Buenas tardes Yuliethbv,

    La configuración del ruteo debe ser configurada en el swtich Cisco ya que este equipo tendría la finalidad de re direccionar los paquetes hacia internet o desde este. También se debe configurar en este el NAT para traducir de IP’s públicas a privadas y al revés para tener acceso a internet. Resumiendo, estos dos servicios deben estar configurados en el router.

    Le muestro una configuración típica de un NAT configurado en un Router Cisco:

    interface FastEthernet0/0

    ip address 192.168.100.30 255.255.255.240

    ip nat inside

    duplex auto

    speed auto

    !

    interface Serial0/0

    ip address 192.0.2.113 255.255.255.0

    encapsulation frame-relay

    ip nat outside

    !

    ip nat pool mypool 198.18.184.105 198.18.184.110 netmask 255.255.255.248

    ip nat inside source list 1 pool mypool overload

    ip classless

    !

    !

    access-list 1 permit 192.168.100.16 0.0.0.15

    !

    !

    Si requiere más asistencia con respecto a la configuración que esta realizando, por favor proceda a contactar nuestro departamento de Soporte Técnico para Servidores.

    Saludos cordiales,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

    Síguenos en @DellAyudaPRO nuestro nuevo canal de soporte.

  • para llamar a solicitar el servicio. qe necesito tener preparado para qe me realicen la kotizacion?

  • Buenas tardes Yuliethbv,

    Por favor mándenos un correo a la dirección ts_prosupport@dell.com con su número de teléfono,  un Especialista del Departamento de Soporte Técnico para Servidores Dell le estará llamando a la brevedad posible para esclarecer cualquier duda que tenga.

    Saludos cordiales,

    Dell-Juan E

    Dell | Social Media Outreach | Global Social Media & Community

    Síguenos en @DellAyudaPRO nuestro nuevo canal de soporte.

  • bueno, muchas gracias, enviare el email!

    muy gentil por su colaboracion, :)

  • Hola yuliethbv, encontraste la forma de resolver lo que planteas es que actualmente se me presenta el mismo problema.